"Connection Due" or "Connection Required" or "Connection Required by Post" message on the mailstation and DM series

Connect your meter to resolve a "Connection Due" or "Connection Required" or "Connection Required by Post" message on the mailstation, mailstation2, DM100i, DM125, DM200L, DM225, DM300C, DM400C, DM450C and DM475.
Products affected: mailstation™, mailstation2™, DM100®i, DM125™, DM200L™, DM225™, DM300C™, DM400C™, DM450C™, DM475™

Issue

Alert: The USPS has discontinued all IBI meter technology, and many devices must be returned and withdrawn from service by the end of 2024. If your device is affected, new business rules will disrupt your mailing operation. Check Your Account to see if your device is affected and contact your Account Representative to migrate to a compliant solution.

Your meter displays the message "Connection Due" or "Connection Required" or "Connection Required by Post" and does not run mail.

Cause

USPS® regulations require that your meter get inspected periodically. This inspection occurs automatically when you connect your meter to the Pitney Bowes Data Center to refill postage or perform a balance inquiry. 

Resolution

Follow these steps to connect the meter to the Pitney Bowes Data Center to clear the message:
  1. Make sure that your meter is connected to access the Pitney Bowes Data Center using:
  2. Select Connect Now or have your meter check your PB Postage (PBP) balance.
    Important: It is unnecessary for you to add funds to your meter to clear this message.
  3. Follow the prompts on your screen to complete any pending downloads.

Related topics

  • If your meter cannot connect to the Pitney Bowes Data Center, see Resolving meter connection issues for your meter model.
  • See the Install Guide that came with your meter for setup instructions. Find install guides on the support page for your meter model.

UPDATED: September 25, 2024