No power, no display or a blank screen on the mailstation series

Your meter may have lost power, or be in sleep mode, or your display settings may not be optimized correctly. Learn how to resolve no power, no display, or a blank screen on the mailstation and mailstation2.
Products affected: mailstation™, mailstation2™

Issue

Alert: The USPS has discontinued all IBI meter technology, and many devices must be returned and withdrawn from service by the end of 2024. If your device is affected, new business rules will disrupt your mailing operation. Check Your Account to see if your device is affected and contact your Account Representative to migrate to a compliant solution.

The meter display screen is blank.

Cause

Your meter may have lost power, be in sleep mode, or your display settings may not be optimized correctly.

Resolution

Try these solutions to resolve your issue:

Solution 1: Check sleep mode

The meter may be in sleep mode.
  1. Press any button to wake up the meter.

Solution 2: Check the power to the meter

  1. Check that the power cord plugs securely into the back of your meter and a working electrical outlet. If the power cord plugs into a power strip, plug the power cord into a wall outlet instead.
  2. Restart your meter:
    1. Remove the power cord.
    2. Wait for at least one minute.
    3. Plug the power cord back in securely.
  3. The print cartridge should move while powering up which indicates you have power to your meter.

UPDATED: September 25, 2024